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The following parameters and switches can be used while running 
the On‑demand scanner from the command line:

General options:
–	 help	 show help and quit
–	 version	 show version information and quit
–	 base‑dir = FOLDER	 load modules from FOLDER
–	 quar‑dir = FOLDER	 quarantine FOLDER
–	 aind	 show activity indicator
--	 auto	 scans all hard drives in the cleaning mode

Targets:
–	 files	 scan files (default)
–	 no‑files	 do not scan files
–	 boots	 scan boot sectors (default)
–	 no‑boots	 do not scan boot sectors
–	 arch	 scan archives (default)
–	 no‑arch	 do not scan archives
–	 max‑archive‑level = LEVEL	 maximum archive nesting LEVEL
–	 scan‑timeout = LIMIT	 scan archives for LIMIT seconds at 

maximum. If the 	 scanning time reaches this limit, the 
scanning of the 	 archive is stopped and the scan will 
continue with the 	 next file

–	 max‑arch‑size=SIZE	 scan only the first SIZE bytes in 
	 archives (default 0 =  unlimited)

–	 mail	 scan email files
–	 no‑mail	 do not scan email files
–	 sfx	 scan self‑extracting archives
–	 no‑sfx	 do not scan self‑extracting archives
–	 rtp	 scan runtime packers
–	 no‑rtp	 do not scan runtime packers
–	 exclude = FOLDER	 exclude FOLDER from scanning
–	 subdir	 scan subfolders (default)
–	 no‑subdir	 do not scan subfolders
–	 max‑subdir‑level = LEVEL	 maximum subfolder nesting LEVEL  

	 (default 0  = unlimited)
–	 symlink	 follow symbolic links (default)
–	 no‑symlink	 skip symbolic links
–	 ext‑remove = EXTENSIONS	
–	 ext‑exclude = EXTENSIONS	 exclude EXTENSIONS delimited by 

colon from scanning

Methods:
–	 adware	 scan for Adware/Spyware/Riskware
–	 no‑adware	 do not scan for Adware/Spyware/

Riskware
–	 unsafe	 scan for potentially unsafe 

applications
–	 no‑unsafe	 do not scan for potentially unsafe 

applications
–	 unwanted	 scan for potentially unwanted 

applications
–	 no‑unwanted	 do not scan for potentially unwanted 

applications
–	 pattern	 use signatures
–	 no‑pattern	 do not use signatures
–	 heur	 enable heuristics
–	 no‑heur	 disable heuristics
–	 adv‑heur	 enable advanced heuristics
–	 no‑adv‑heur	 disable advanced heuristics

Cleaning:
–	 action = ACTION	 perform ACTION on infected objects. 

Available actions:  
none, clean, prompt

–	 quarantine	 copy infected files to Quarantine 
(supplements ACTION)

–	 no‑quarantine	 do not copy infected files to 
Quarantine

5.2	 Export / import settings

Importing and exporting configurations of ESET NOD32 Antivirus is 
available in Advanced mode under Setup.

Both import and export use the .xml file type. Import and export are 
useful if you need to backup the current configuration of ESET NOD32 
Antivirus to be able to use it later. The export settings option is also 
convenient for users who wish to use their preferred configuration of 
ESET NOD32 Antivirus on multiple systems - they can easily import an 
.xml file to transfer the desired settings.

5.2.1	 Import settings

Importing a configuration is very easy. From the main menu, click 
Setup > Import and export settings, and then select the Import 
settings option. Enter the name of the configuration file or click the ... 
button to browse for the configuration file you wish to import.

5.2.2	 Export settings

The steps to export a configuration are very similar. From the main 
menu, click Setup > Import and export settings.... Select the 
Export settings option and enter the name of the configuration file. 
Use the browser to select a location on your computer to save the 
configuration file.

5.3	 Command Line

ESET NOD32 Antivirus’s antivirus module can be launched via the 
command line – manually (with the “ecls” command) or with a batch 
(“bat”) file.
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Logs:
–	 log‑file=FILE	 log output to FILE
–	 log‑rewrite	 overwrite output file  

	 (default – append)
–	 log‑all	 log also clean files
–	 no‑log‑all	 do not log clean files (default)

Possible exit codes of the scan:

0	 – no threat found
1	 – threat found but not cleaned
10	 – some infected files remained
101	 – archive error
102	 – access error
103	 – internal error

NOTE: Exit codes greater than 100 mean that the file was not scanned 
and thus can be infected.

5.4	 ESET SysInspector

ESET SysInspector is an application that thoroughly inspects your 
computer and displays system data in a comprehensive way. 
Information about installed drivers and applications, network 
connections or important registry entries can help you investigate 
suspicious system behavior and determine whether it is due to 
software/hardware incompatibility or malware infection.

You can access SysInspector two ways: From the integrated version 
in ESET NOD32 Antivirus or by downloading the standalone version 
(SysInspector.exe) for free from ESET’s website. To open SysInspector, 
activate Advanced mode by pressing CTRL + M and clicking  
Tools > SysInspector. Both versions are identical in function and 
have the same program controls. The only difference is how outputs 
are managed. The downloaded and integrated versions each allow 
you to export system snapshots to an .xml file and save them to disk. 
However,the integrated version also allows you to store your system 
snapshots directly in Tools > SysInspector (for more information see 
section 5.4.1.4, ”SysInspector as part of ESET NOD32 Antivirus 4”).

Please allow some time while ESET SysInspector scans your computer. 
It may take from 10 seconds up to a few minutes depending on 
your hardware configuration, operating system and the number of 
applications installed on your computer.

5.4.1	 User Interface and application usage

The main window includes four sections – Program Controls on the 
top, the Navigation window on the left, and the Description window 
on the right which is directly above the Details window.

5.4.1.1	 Program Controls

This section contains descriptions of all program controls available in 
ESET SysInspector

File – Click here to store your current report status for later 
investigation or to open a previously stored report. If you want to 
publish your report we recommend you choose Generate > Suitable 
for sending. This report format omits sensitive information.

NOTE: You can open previously stored ESET SysInspector reports by 
dragging-and-dropping them into the main window.

Tree – Allows you to expand or close all nodes.

List – Contains functions for easier navigation within the program as 
well as various other functions like finding information online. 

NOTE: Items highlighted in red are unknown and are therefore 
considered potentially dangerous. If an item is in red, it does not 
automatically mean that you can delete the file. Before deleting, 
please make sure that the files are truly dangerous or not needed.

Help – Contains information about the application and its functions.

Detail – Influences information displayed in other sections of 
SysInspector. In Basic mode you have access to information used to 
find solutions for common problems in your system. In Medium mode 
the program displays less used details. In Full mode ESET SysInspector 
displays detailed information needed to solve more complex 
problems.

Item filtering – The most effective use of Item filtering is to find 
suspicious files or registry entries in your system. By adjusting the 
slider you can filter items by their Risk Level. If the slider is set to the 
far left (Risk Level 1) then all items are displayed. By moving the slider 
to the right, the program filters out items that are less risky than the 
current Risk Level and only displays items that are more suspicious 
than the displayed level. With the slider on the far right, the program 
displays only known harmful items.

All items within the range 6 to 9 can pose a security risk. If you do not 
have an ESET security solution installed, we recommend you scan your 
system with the ESET Online scanner after the program has found any 
high-risk items. ESET Online scanner is a free service and can be found 
at http://www.eset.com/onlinescan/.

NOTE: The Risk level of an item can be determined quickly by 
comparing the color of the item with the color on the Risk Level slider.

Search – Search can be used to quickly find a specific item by its name 
or part of its name. The results of search requests are displayed in the 
Description window. 

Return – By clicking the back or forward arrow you can return to 
previously displayed information in the Description window. 

Status section – Displays the current node in the Navigation window.

5.4.1.2	 Navigating in ESET SysInspector

ESET SysInspector divides various types of information into several 
basic sections called nodes. If available, you may find additional 
details by expanding each node into its subnodes. To open or collapse 
a node just double-click the name of the node or click  or  next to 
the name of the node. As you browse through the tree structure of 
nodes and subnodes in the Navigation window you may find various 
details for each node shown in the Description window. If you browse 
through items in the Description window, additional details for each 
item may display in the Details window.

http://www.eset.com/onlinescan/
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Below are descriptions of the main nodes in the Navigation window 
and related information in the Description and Details windows.

Running processes  – This node contains information about 
applications and processes running at the time the report was 
generated. The Description window displays details for each process, 
such as dynamic libraries used by the process and their location in the 
system, the name of the application’s vendor, the risk level of the file, 
etc.

The Details window contains additional information about items 
selected in the Description window such as the file size or its hash.

NOTE: An operating system is comprised of several important kernel 
processes which run continually in order to provide basic functions  
vital to other applications. In certain cases, such processes are 
displayed in ESET SysInspector as a file path beginning with \??\. These 
symbols indicate a safe and accurate configuration.

Network connections – The Description window contains a list of 
processes and applications communicating over the network. The 
communication protocol used is shown in the Navigation window 
(TCP or UDP) along with the remote address to which the application 
is connecting. You can also check DNS assigned IP addresses.

The Details window contains additional information about items 
selected in the Description window such as the file size or its hash.

Important Registry Entries – Contains a list of selected registry 
entries often related to various problems with your system such as 
specifying startup programs, browser helper objects (BHO), etc.

In the Description window you may find which files are related to 
specific registry entries. You may see additional details in the Details 
window.

Services – The Description window contains a list of files registered as 
Windows Services. You may check the way the service is set to start 
along with specific details about the file in the Details window.

Drivers – The list of drivers installed on the system.

Critical files – The Description window displays content of critical files 
related to the Microsoft Windows®operating system.

System information – Contains detailed information about hardware 
and software along with information about set environmental 
variables and user rights.

File details – A list of important system files and files in the Program 
Files folder. Additional information specific to the files can be found in 
the Description and Details windows. 

About – Information about ESET SysInspector

 5.4.1.3	 Compare

The Compare feature allows you to compare two existing SysInspector 
logs in order to highlight  common to both logs. This feature is useful 
if you want to keep track of changes to the system and may allow you 
to detect the activity of malicious code.

After launching, ESET SysInspector creates a new log, which is 
displayed in a new window. Navigate to File > Save Log to save a 
log to a file. Log files can later be opened and viewed. To open an 
existing log, click File > Open Log. In the main program window, ESET 
SysInspector always displays one log at a time.

If you are comparing two logs, it’s important to compare a currently 
active log to a log saved in a file. To compare logs, use the option 
File > Compare Log and choose Select file. The selected log will 
be compared to the active one in the main program windows. The 
resulting, so called comparative log will display only differences 
between those two logs. 

NOTE: If you compare two log files, select File > Save Log, and save 
it as a .zip file, both files are saved. If you later open this file, the 
contained logs are automatically compared.

Next to the displayed items, SysInspector shows symbols identifying 
differences between the compared logs. Items marked by a  can 
only be found in the active log and were not present in the opened 
comparative log. Items marked by a  on the other hand, were 
present only in the opened log and are missing in the active one. 

Description of all symbols that can be displayed next to items:

 new value, not present in the previous log

 tree structure section contains new values

 removed value, present in the previous log only

 tree structure section contains removed values

 value / file has been changed

 tree structure section contains modified values / files

 the risk level has decreased / it was higher in the previous log

 the risk level has increased  / it was lower in the previous log

The explanation section displayed in the bottom left corner describes 
all symbols and also displays the names of logs which are being 
compared. 

Any comparative log can be saved to a file and opened at a later time.

Example: – Generate and save a log, recording original information 
about the system, to a file named previous.xml. After changes to the 
system have been made, open SysInspector and let it generate a new 
log. Save it to a file named current.xml. 

In order to track changes between those two logs, click  
File > Compare Log. The program will create a comparative log 
showing differences between the logs. 

The same result can be achieved if you use the following command 
line option: 

SysIsnpector.exe current.xml previous.xml
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5.4.1.4	 SysInspector as part of ESET NOD32 Antivirus 4

To open SysInspector in ESET NOD32 Antivirus, click Tools > 
SysInspector. The management system in the SysInspector window 
is similar to that of computer scan logs, or scheduled tasks. All 
operations with system snapshots - create, view, compare, remove 
and export - are accessible within one or two clicks.

The SysInspector window contains basic information about the 
created snapshots such as create time, short comment, name of the 
user that created the snapshot and snapshot status.

To Compare, Add..., or Remove snapshots, use the corresponding 
buttons located below the list of snapshots in the SysInspector 
window. Those options are also available from the context menu. 

To view the selected system snapshot, use the View context menu 
option. To export the selected snapshot to a file, right-click it and 
select Export.... A detailed description of the available options is 
shown below:

Compare - Allows you to compare two existing logs. This feature is 
useful if you want to track changes between the current log and an 
older log. For this option to take effect you must select two snapshots 
to be compared.

Add – Creates a new record. Before that you must enter a short 
comment about the record. To see the snapshot creation progress (of 
the currently generated snapshot) in percent, see the Status column. 
All completed snapshots are marked by the Created status. 

Remove  – Removes entries from the list

Show – Displays the selected snapshot. Alternatively, you can double-
click the selected entry.

Export... – Saves the selected entry in an .xml file (as well as a .zip 
version)

5.5	 ESET SysRescue

ESET SysRescue (ESR) is a utility which enables you to create a 
bootable disk containing ESET NOD32 Antivirus 4 (EAV). The main 
advantage of ESET Recovery CD is that EAV runs independent of the 
host operating system, while it has direct access to the disk and the 
entire file system. This makes it possible to remove those infiltrations 
that normally could not be deleted, e.g., when the operating system is 
running, etc.

5.5.1	 Minimum requirements

ESET SysRescue (ESR) works in the Microsoft Windows Preinstallation 
Environment (Windows PE) version 2.x, which is based on Windows 
Vista. Windows PE is a part of the free package Windows Automated 
Installation Kit (Windows AIK), and therefore Windows AIK must be 
installed before creating ESR. Due to the support of the 32-bit version 
of Windows PE, ESR can be created in the 32-bit version of EAV only. 
ESR supports Windows AIK 1.1 and later. ESR is available in EAV 4.0 and 
later.

5.5.2	 How to create a rescue CD

If the minimum requirements for the creation of ESET SysRescue (ESR) 
CD are met, it is quite an easy task to accomplish. To launch the ESR 
wizard, click Start > Programs > ESET > ESET NOD32 Antivirus 4 > 
ESET SysRescue.

First, the wizard checks for the presence of Windows AIK and a 
suitable device for the boot media creation.

In the next step select the target media where ESR will be located. In 
addition to CD/DVD/USB you can choose to save ESR in an .iso file. 
Later, you can burn the .iso image on CD/DVD, or use it in other ways 
(e.g., in a virtual environment such as VmWare or Virtualbox).

After you have specified all parameters, you will see a compilation 
preview in the last step of ESET SysRescue wizard. Check the 
parameters and start the compilation. The available options include:

Folders 
ESET Antivirus 
Advanced 
Bootable USB device 
Burning

5.5.2.1	 Folders

Temporary folder – Working directory for files required during ESET 
SysRescue compilation. 

ISO folder – Folder where the resulting .iso file is saved after the 
compilation is completed. 

The list on this tab shows all local and mapped network drives 
together with the available free space. If any of the folders here are 
located on a drive with insufficient free space, we recommend that 
you select another drive with more free space available. Otherwise 
compilation may exit prematurely due to insufficient free disk space. 

External applications – Allows you to specify additional programs 
that will be run or installed after booting from a SysRescue medium.

Include external applications – Allows you to add external programs 
to the SysRescue compilation

Selected folder – Folder in which programs to be added to the 
SysRescue disk are located

5.5.2.2	 ESET Antivirus

To create an ESET SysRescue CD, you can select two sources of ESET 
files to be used by the compiler. 

EAV folder – Files already contained in the folder to which the ESET 
product is installed on your computer 

MSI file – Files contained in the .msi installer are used 

Profile – You can use one of the following two sources of username 
and password: 

Installed EAV – Username and password are copied from the 
currently installed ESET security product 

From user – Username and password entered in the corresponding 
text boxes below are used

NOTE: The ESET security product on the ESET SysRescue CD is 
updated either from the Internet or from the computer running the 
ESET SysRescue CD.

5.5.2.3	 Advanced

The Advanced tab lets you optimize ESET SysRescue CD according to 
your computer’s memory capacity. Select 512 MB and more to write 
the content of the CD to the operating memory (RAM). If you select 
less than 512 MB, the recovery CD will be permanently accessed when 
WinPE is running. 
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External drivers  – This section explains how to add drivers for your 
specific hardware (e.g., network adapter). Although WinPE is based 
on Windows Vista SP1, which supports a large range of hardware, 
occasionally hardware is not recognized. This will required that you 
add a driver manually. 

There are two ways of introducing a driver into an ESET SysRescue 
compilation - manually (the Add button) and automatically (the Aut.
Search button). If you manually add a driver, you need to select the 
path to the corresponding .inf file (applicable *.sys file must also be 
present in this folder). Using the Aut. Search button automatically 
locates the driver in the operating system of the given computer. We 
recommend you use this option only if the original computer on which 
the SysRescue disc was created and the computer you are restoring to 
use the same network adapter. During creation, the ESET SysRescue 
the driver is introduced into the compilation so you do not need to 
look for it later. 

5.5.2.4	 Bootable USB device

If you have selected USB device as your target medium, you can select 
one of the available USB media on the Bootable USB device tab (in 
case there are more USB devices).

Warning: The selected USB device will be formatted during ESET 
SysRescue creation. All data on the device will be deleted.

5.5.2.5	 Burn

If you have selected CD/DVD as your target medium, you can specify 
additional burning parameters on the Burn tab.

Delete ISO file – Select this option to delete .iso files after the ESET 
Rescue CD is created.

Deletion enabled – Allows you to select fast erasing and complete 
erasing.

Burning device – Select the drive to be used for burning. 

Warning: This is the default option. If a rewritable CD/DVD is used, all 
data on the CD/DVD will be erased.

The Medium section contains information about the current medium 
inserted in your CD/DVD device.

Burning speed – Select the desired speed from the drop-down menu. 
The capabilities of your burning device and the type of CD/DVD used 
should be considered when selecting the burning speed.

5.5.3	 Working with ESET SysRescue

For the rescue CD/DVD/USB to work effectively, you must start your 
computer from the ESET SysRescue boot media. Boot priority can be 
modified in the BIOS. Alternatively, you can invoke the boot menu 
during computer startup - usually using one of the F9 - F12 keys 
depending on the version of your motherboard/BIOS.

After booting up, EAV will start. Since ESET SysRescue is used only in 
specific situations, some protection modules and program features 
present in the standard version of EAV are not needed; their list is 
narrowed down to Computer scan, Update, and some sections in 
Setup. The ability to update the virus signature database is the most 
important feature of ESET SysRescue, we recommend that you update 
the program prior starting a Computer scan.

5.5.3.1	 Using ESET SysRescue

Suppose that computers in the network have been infected by a virus 
which modifies executable (.exe) files. EAV is capable of cleaning all 
infected files except for explorer.exe, which cannot be cleaned, even in 
Safe mode.

This is because explorer.exe, as one of the essential  Windows 
processes, is launched in Safe mode as well. EAV would not be able to 
perform any action with the file and it would remain infected.

In this type of scenario, you could use ESET SysRescue to solve the 
problem. ESET SysRescue does not require any component of the host 
operating system and is therefore capable of processing (cleaning, 
deleting) any file on the disk.
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6.	 Glossary

6.1	 Types of infiltrations

An Infiltration is a piece of malicious software trying to enter and/or 
damage a user’s computer.

6.1.1	 Viruses

A computer virus is an infiltration that corrupts existing files on your 
computer. Viruses are named after biological viruses, because they use 
similar techniques to spread from one computer to another.

Computer viruses mainly attack executable files and documents. To 
replicate, a virus attaches its “body“ to the end of a target file. In short, 
this is how a computer virus works: after execution of the infected 
file, the virus activates itself (before the original application) and 
performs its predefined task. Only after that is the original application 
allowed to run. A virus cannot infect a computer unless a user, either 
accidentally or deliberately, runs or opens the malicious program by 
him/herself.

Computer viruses can range in purpose and severity. Some of them 
are extremely dangerous because of their ability to purposely delete 
files from a hard drive. On the other hand, some viruses do not cause 
any damage – they only serve to annoy the user and demonstrate the 
technical skills of their authors.

It is important to note that viruses (when compared to trojans or 
spyware) are increasingly rare because they are not commercially 
enticing for malicious software authors. Additionally, the term “virus” 
is often used incorrectly to cover all types of infiltrations. This usage 
is gradually being overcome and replaced by the new, more accurate 
term “malware” (malicious software).

If your computer is infected with a virus, it is necessary to restore 
infected files to their original state – i.e., to clean them by using an 
antivirus program.

Examples of viruses are: OneHalf, Tenga, and Yankee Doodle.

6.1.2	 Worms

A computer worm is a program containing malicious code that 
attacks host computers and spreads via a network. The basic 
difference between a virus and a worm is that worms have the ability 
to replicate and travel by themselves – they are not dependent on host 
files (or boot sectors). Worms spread through email addresses in your 
contact list or exploit security vulnerabilities in network applications. 

Worms are therefore much more viable than computer viruses. Due 
to the wide availability of the Internet, they can spread across the 
globe within hours of their release – in some cases, even in minutes. 
This ability to replicate independently and rapidly makes them more 
dangerous than other types of malware.

A worm activated in a system can cause a number of inconveniences: 
It can delete files, degrade system performance, or even deactivate 
programs. The nature of a computer worm qualifies it as a “means of 
transport“ for other types of infiltrations.

If your computer is infected with a worm, we recommend you delete 
the infected files because they likely contain malicious code.

Examples of well‑known worms are: Lovsan/Blaster, Stration/
Warezov, Bagle, and Netsky.

6.1.3	 Trojan horses

Historically, computer trojan horses have been defined as a class of 
infiltrations which attempt to present themselves as useful programs, 
thus tricking users into letting them run. But it is important to note 
that this was true for trojan horses in the past–today, there is no 
longer a need for them to disguise themselves. Their sole purpose 
is to infiltrate as easily as possible and accomplish their malicious 

goals. “Trojan horse” has become a very general term describing any 
infiltration not falling under any specific class of infiltration.

Since this is a very broad category, it is often divided into many 
subcategories:

Downloader – A malicious program with the ability to download 
other infiltrations from the Internet.

Dropper – A type of trojan horse designed to drop other types 
of malware onto compromised computers.

Backdoor – An application which communicates with remote 
attackers, allowing them to gain access to a system and to take 
control of it.

Keylogger – (keystroke logger) – A program which records each 
keystroke that a user types and sends the information to remote 
attackers.

Dialer – Dialers are programs designed to connect to premium‑rate 
numbers. It is almost impossible for a user to notice that a new 
connection was created. Dialers can only cause damage to users with 
dial‑up modems, which are no longer regularly used.

Trojan horses usually take the form of executable files with the 
extension .exe. If a file on your computer is detected as a trojan horse, 
it is advisable to delete it, since it most likely contains malicious code.

Examples of well‑known trojans are: NetBus, Trojandownloader.
Small.ZL, Slapper

6.1.4	 Rootkits

Rootkits are malicious programs that grant Internet attackers 
unlimited access to a system, while concealing their presence. 
Rootkits, after accessing a system (usually exploiting a system 
vulnerability), use functions in the operating system to avoid 
detection by antivirus software: they conceal processes, files and 
Windows registry data. For this reason, it is almost impossible to 
detect them using ordinary testing techniques.

There are two levels of detection to prevent rootkits:

1.	 When they try to access a system. They are still not present, 
and are therefore inactive. Most antivirus systems are able to 
eliminate rootkits at this level (assuming that they actually detect 
such files as being infected).

2.	 When they are hidden from the usual testing. ESET NOD32 
Antivirus users have the advantage of Anti‑Stealth technology, 
which is also able to detect and eliminate active rootkits.

6.1.5	 Adware

Adware is a short for advertising‑supported software. Programs 
displaying advertising material fall under this category. Adware 
applications often automatically open a new pop‑up window 
containing advertisements in an Internet browser, or change the 
browser’s home page. Adware is frequently bundled with freeware 
programs, allowing their creators to cover development costs of their 
(usually useful) applications.

Adware itself is not dangerous – users will only be bothered with 
advertisements. Its danger lies in the fact that adware may also 
perform tracking functions (as spyware does).

If you decide to use a freeware product, please pay particular 
attention to the installation program. The installer will most likely 
notify you of the installation of an extra adware program. Often you 
will be allowed to cancel it and install the program without adware. 
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Some programs will not install without adware, or their functionality 
will be limited. This means that adware may often access the system 
in a “legal” way, because users have agreed to it. In this case, it is better 
to be safe than sorry.If there is a file detected as adware on your 
computer, it is advisable to delete it, since there is a high probability 
that it contains malicious code.

6.1.6	 Spyware

This category covers all applications which send private information 
without user consent/awareness. Spyware uses tracking functions to 
send various statistical data such as a list of visited websites, email 
addresses from the user‘s contact list, or a list of recorded keystrokes.

The authors of spyware claim that these techniques aim to find out 
more about users’ needs and interests and allow better‑targeted 
advertisement. The problem is that there is no clear distinction 
between useful and malicious applications and no one can be sure 
that the retrieved information will not be misused. The data obtained 
by spyware applications may contain security codes, PINs, bank 
account numbers, etc. Spyware is often bundled with free versions 
of a program by its author in order to generate revenue or to offer an 
incentive for purchasing the software. Often, users are informed of 
the presence of spyware during a program‘s installation to give them 
an incentive to upgrade to a paid version without it.

Examples of well‑known freeware products which come bundled 
with spyware are client applications of P2P (peer‑to‑peer) networks. 
Spyfalcon or Spy Sheriff (and many more) belong to a specific spyware 
subcategory – they appear to be antispyware programs, but in fact 
they are spyware programs themselves.

If a file is detected as spyware on your computer, it is advisable to 
delete it, since there is a high probability that it contains malicious 
code.

6.1.7	 Potentially unsafe applications

There are many legitimate programs whose function is to simplify 
the administration of networked computers. However, in the wrong 
hands they may be misused for malicious purposes. ESET NOD32 
Antivirus provides the option to detect such threats.

“Potentially unsafe applications” is the classification used for 
commercial, legitimate software. This classification includes programs 

such as remote access tools, password‑cracking applications, and 
keyloggers (a program that records each keystroke a user types).

If you find that there is a potentially unsafe application present and 
running on your computer (and you did not install it), please consult 
your network administrator or remove the application.

6.1.8	 Potentially unwanted applications

Potentially unwanted applications are not necessarily intended to 
be malicious, but may affect the performance of your computer 
in a negative way. Such applications usually require consent for 
installation. If they are present on your computer, your system 
behaves differently (compared to the state before their installation). 
The most significant changes are:

New windows you haven’t seen previously are opened •	

Activation and running of hidden processes •	

Increased usage of system resources •	

Changes in search results •	

Application communicates with remote servers •	


